Основные сведения

Лекция No 1

Основные сведения. Простые вычисления

MathCAD - система визуальных математических расчетов. Основная идея MathCAD состоит в том, что вычисляемые выражения записываются в визуальной форме, максимально приближенной к математической записи, привычной для человека. Используется принцип WYSIWYG (What You See Is What You Get - «что видите, то и получаете»).

Возможности системы:

1. Числовые расчеты со скалярами, матрицами и векторами (матрицами из одного столбца). Возможны расчеты с использованием комплексных чисел.

2. Аналитические преобразования: интегрирование, дифференцирование, вычисление пределов, сумм и произведений рядов, упрощение, преобразования Лапласа и Фурье и др.

3. Определение законов вычисления элементов матриц, что позволяет реализовать итерационные вычисления, в том числе по рекуррентным формулам.

4. Работа со стандартными функциями: интерполяция, экстраполяция, численное интегрирование, матричные функции и др.

5. Определение своих функций.

6. Построение двумерных и трехмерных графиков различных видов.

7. Решение систем линейных и нелинейных уравнений.

8. Решение оптимизационных задач вида: найти значения переменных, при которых функция принимает минимальное или максимальное значение.

9. Решение дифференциальных уравнений (обыкновенные дифференциальные уравнения и системы уравнений; уравнения Пуассона и Лапласа).

10. Элементы программирования.

При запуске системы MathCAD появляется основное окно, которое обычно содержит три панели (стандартную, форматирования текста, математическую) и рабочую область с автоматически созданным листом вычислений. На математической панели находятся кнопки, при нажатии на которые открываются дополнительные панели с шаблонами ввода различных выражений: Calculator (знаки некоторых основных функций и операций), Calculus (шаблоны операций интегрирования, дифференциорования, пределов и других), Evaluation (операторы присваивания и вычисления), Graph (графики), Greek (символы греческого алфавита), Matrix (операции векторного и скалярного произведений, транспонирования, векторной суммы, вычисления определителя матрицы), Programming (элементы программирования), Boolean (логические операции), Symbolic (различного рода аналитические преобразования). Включать и отключать панели также можно из верхнего меню в разделе View\Toolbars или Просмотр\Панели (здесь и далее при указании разделов меню будут даваться варианты наименований для русифицированной и англоязычной версий системы).

На лист вычислений должны записываться все выражения и формулы, с которыми идет работа, также можно вставлять текст и графические изображения. MathCAD может одновременно работать с несколькими листами. Создание нового листа осуществляется из верхнего меню - File\New или Файл\Новый. Загрузить уже имеющийся лист - File\Open или Файл\Открыть. Сохранить созданный лист - File\Save или Файл\Сохранить. Переключение между загруженными листами - комбинация клавиш Ctrl-F6.

Запись формул и выражений на лист вычислений

Любая формула может быть записана в любом месте листа. Необходимо щелкнуть мышью в предполагаемой точке ввода формулы, там должен появиться указатель ввода - крест. Ввод обычно производится как с клавиатуры, так и с помощью мыши. С клавиатуры всегда вводятся числа и имена переменных. Знаки арифметических операций и названия функций обычно также вводятся с клавиатуры.

Таблица 1. Ввод некоторых типовых выражений и шаблонов MathCAD с клавиатуры

Требуемое действие | Вид выражения на листе MathCAD | Последовательность нажатий клавиш
Умножение F на X |  | F*X
Деление F на X |  | F/X
Возведение F в степень A | FA | F^A
Квадратный корень из y |  | \y
Ввод комплексного числа. Необходимо обратить внимание на то, что при вводе комплексной части не следует записывать операцию умножения. В приведенном примере просто последовательно нажимаются клавиши «2» и «j» | 1+2j | 1+2j
Модуль z. Здесь и далее в фигурных скобках будут перечисляться клавиши, которые необходимо нажимать одновременно. В данном случае после нажатия клавиши с буквой «z» необходимо одновременно нажать клавиши «Shift» и «\» |  | z {Shift \}
Сопряженное к z комплексное число |  | z {Shift "}
Числовое вычисление выражения 1+2 | 1+2= | 1+2=
Аналитическое вычисление выражения A. Результатом такого вычисления является не число, а формула (например, результат вычисления интеграла) |  | A {Ctrl .}
Присваивание переменной A значения 5 | A:=5 | A:5
Ввод логического равенства. Здесь прямых вычилений не происходит, лишь устанавливаем тот факт, что одно выражение равно другому выражению. Обычно такой оператор используется при записи уравнений, решаемых в блоке Given-Find. Иногда используется для ввода поясняющих (не вычисляемых) формул, например F = ma | A=x+y | A {Ctrl =} x+y
Определение последовательности F в диапазоне от 10 до 15 с шагом 1. F = 10,11,12,13,14,15 | F:=10..15 | F : 1 ; 10
Определение последовательности F в диапазоне от 2 до 10 с шагом 2. F = 2,4,6,8,10 | F:=2,4..10 | F : 2 , 4 ; 10
i-й элемент вектора F | Fi | F [ i
Элемент матрицы F с индексами (i, j) | Fi,j | F [ i , j
Ввод переменной с вспомогательным индексом. Здесь индекс - только часть имени | Fmax | F.max
Транспонирование матрицы. Не следует путать его с возведением в степень | AT | A {Ctrl 1}
Поэлементное умножение матриц. Здесь клавиша «пробел» используется для смены уровня ввода (будет разъяснено далее) |  | A*B пробел {Ctrl -}
Ввод матрицы или вектора. После нажатия Ctrl-M откроется окно, в котором необходимо указать количество строк (в пункте Rows) и столбцов (в пункте Columns) |  | {Ctrl M}
Корень n-й степени из y |  | {Ctrl \} y
Первая производная |  | {Shift /}
Символ производной в записи начальных условий к дифференциальным уравнениям. Используется в блоке Given-Odesolve | x’(t) | x {Ctrl F7} ( t )
Двусторонний предел |  | {Ctrl L}
Неопределенный интеграл |  | {Ctrl I}
Греческие символы. Вводится буква латинского алфавита (обычно произносится так же, как первая буква названия греческого символа) и нажимается Ctrl-G |  | a b d e f g j l m p r t w y {Ctrl G}

Здесь перечислены лишь основные шаблоны. Совершенно излишне запоминать все приведенные комбинации клавиш, поскольку эти и остальные шаблоны доступны из панелей, открывающихся при нажатии различных кнопок математической панели. Достаточно щелкнуть мышью по шаблону - и он появится на листе в месте, отмеченном указателем ввода.

В последних пяти примерах таблицы и во многих других стандартных выражениях после нажатия указанной последовательности клавиш необходимо ввести данные в места, отмеченные небольшими черными квадратами, называемыми позициями ввода. Чтобы ввести данные в такую позицию, необходимо сначала либо щелкнуть по ней мышью, либо передвинуть в данную позицию курсор, пользуясь клавишами управления курсором. В любом случае необходимо добиться того, чтобы курсор подчеркивал только данную позицию и затем вводить данные.

Во время ввода или редактирования формулы MathCAD обводит ее рамкой (рис. 1).

Рис. 1. Формула на листе MathCAD в рамке ввода

Наиболее частая ошибка заключается в том, что в процессе ввода формулы пользователь неосторожно выходит из указанной рамки ввода (при этом рамка исчезает и в рабочей области появляется указатель ввода - крест) и все равно продолжает ввод. При этом на листе вместо одной обычно оказываются две формулы, каждая из которых - лишь часть требуемой. Проблема в том, что визуально эти две формулы могут находиться близко друг к другу и выглядеть как единое целое, но это не так. Единственный способ проверить целостность формулы - щелкнуть по ней мышью. Если все правильно, то в рамке ввода окажется вся формула.

При наборе выражения можно последовательно отменять произведенные действия, нажимая Ctrl-Z. Однако следует учесть, что в младших версиях MathCAD (до MathCAD 11) отмена возможна только до выхода из рамки ввода. Закончить ввод формулы можно, либо нажав Enter или Tab, либо щелкнув мышью где-нибудь вне рамки ввода формулы.

Если при вводе выражения произошла какая-либо ошибка, то ошибочный фрагмент будет автоматически выделен красным цветом.

Для удаления формулы достаточно выделить ее (например, щелкнув мышью) и нажать Ctrl-D. Для перемещения формулы необходимо выделить ее и, ухватившись мышью за появившуюся рамку ввода, переместить. Можно одновременно перемещать блок формул, который необходимо предварительно выделить методом протягивания.

Смена уровня ввода формул

При вводе формул часто возникает необходимость применить какую-либо операцию не к одному элементу выражения, а к некоторой его части из нескольких элементов. Например, необходимо ввести выражение вида [image]. После ввода последовательности «a+b» формула приобретет вид [image]. Курсор подчеркивает символ «b», поэтому если сразу ввести символ деления и затем цифру, то будет введено выражение [image]. Поэтому после ввода «a+b» следует перевести курсор на более низкий уровень, нажав клавишу «пробел». Тогда выражение принимает вид [image], и если далее ввести символ деления и цифру, то будет получена требуемая формула.

Смена уровня ввода с помощью клавиши «пробел» наиболее часто требуется при наборе выражений со степенями, например A-1B.

Примеры простых вычислений

Рис. 2. Фрагмент листа MathCAD с вычисленными выражениями

На рис. 2 приведены примеры аналитического и числового вычислений. Левая часть, включая знаки вычисления, вводится пользователем, правая часть - результат, вычисленный системой MathCAD.

Помимо интегралов система позволяет аналитически вычислять выражения, содержащие производные различных порядков, суммы и произведения рядов, односторонние и двусторонние пределы. В разделе Symbolics верхнего меню также доступны многие операции аналитического преобразования выражений (упрощение, свертка, разложение в ряд, преобразования Лапласа и Фурье и др.)

Вставка текста и рисунков

Чтобы вставить текст, необходимо щелкнуть мышью в той точке листа, где необходим текст, и выполнить команду верхнего меню Insert\Text Region или Вставка\Текстовый регион. Появится рамка, в которую можно ввести текст. При этом иногда возникает необходимость сменить шрифт для правильного отображения русских букв - это можно сделать с помощью списка шрифтов на панели форматирования.

Вставку рисунка проще всего осуществить через буфер обмена. Предварительно необходимо поместить изображение в буфер (например, с помощью графического редактора Paint), затем вернуться в MathCAD и выполнить пункт верхнего меню Edit\Paste или Правка\Вставить.

Вычисления с переменными

Переменные могут использоваться в выражениях MathCAD на тех же правах, что и числовые константы. Имена переменных могут включать латинские и греческие буквы, цифры, знаки подчеркивания и процента, а также вспомогательный индекс. Строчные и прописные буквы различаются, поэтому, например, x и X - две различные переменные.

Чтобы определить переменную, достаточно просто присвоить ей значение. Есть строгое правило порядка записи переменных и выражений с переменными: если в некотором выражении используется переменная, то эта переменная должна быть определена на листе MathCAD либо выше выражения, либо в той же строчке, но левее (рис. 3). Несоблюдение данного правила - одна из наиболее частых ошибок.

а) б)

Рис. 3. Примеры правильной (а) и неправильной (б) последовательностей расположения формул с переменными

Значения переменных можно изменить в любой момент, отредактировав соответствующую формулу. При этом обычно автоматически пересчитываются все формулы, которые прямо или опосредованно зависят от данной переменной. Если же этого не происходит, то необходимо включить автовычисление с помощью верхнего меню MathCAD (пункт Math\Automatic calculation или Математика\Автовычисление).

Пример матричных вычислений: решение системы линейных алгебраических уравнений методом обратной матрицы

Допустим, что необходимо решить следующую систему уравнений:

Воспользуемся матричным методом, когда решение находится по формуле X = A-1B, где A - матрица коэффициентов при переменных системы; B - вектор свободных членов. Поскольку в MathCAD нет понятия вектора, используется матрица из одного столбца. На листе MathCAD (рис. 4) необходимо определить эти матрицы, записать формулу для X и подсчитать X, применив оператор числового вычисления «=».

Рис. 4. Вид листа MathCAD при решении данной задачи


Решение систем уравнений с помощью блока Given-Find

Лекция No 2

Решение систем уравнений с помощью блока Given-Find

Решение систем уравнений MathCAD осуществляет численными методами. При этом должно быть задано некоторое начальное приближение для тех переменных, значение которых необходимо найти. Основываясь на этих начальных данных, MathCAD будет последовательно уточнять решение до тех пор, пока не подберет наиболее точные значения. Проблемы возникают, когда нелинейная система имеет несколько решений. За один раз MathCAD находит только одно решение, которое обычно более близко к заданному начальному приближению. Поэтому в таких случаях необходимо решать систему несколько раз с различными начальными приближениями.

Решающий блок состоит из нескольких компонент, следующих на листе в строго определенном порядке:

1. Начальное приближение (присваивание начальных значений переменным).

2. Директива Given, которую необходимо набрать с клавиатуры.

3. Уравнения, которые необходимо решить. Уравнения вводятся в обычной математической форме, но вместо простого знака равенства «=» используется оператор логического равенства (вводится путем нажатия Ctrl-=).

4. Обращение к функции Find. Аргументами функции являются имена переменных, относительно которых решается система. Функция возвращает вектор значений, где первый элемент соответствует первой переменной в списке аргументов, второй элемент - второй переменной и так далее.

Пример. Решим систему нелинейных уравнений:

Данная система имеет два решения. Найдем одно из них (рис. 5) с начальным приближением x = 0; y = 0.

Рис. 5. Решение системы в MathCAD

Последняя запись - вектор (-1; -2) есть значение, которое вернула функция Find, то есть одно из решений системы. Найти второе решение можно, если взять другое начальное приближение x = 2; y = 2. Тогда функция Find вернет вектор (2; 4).

Начиная с MathCAD 2000 существует возможность одновременно найти несколько решений. Для этого система уравнений и начальные приближения должны быть переписаны в векторной форме (рис. 6). Каждая переменная будет вектором, содержащим столько компонент, сколько решений находится. В системе изменения коснутся преимущественно членов с перемножением переменных. Допустим, что в уравнении присутствует выражение x*x. Если x = (x1; x2) - вектор, то [image]. Нам же необходим результат поэлементного перемножения [image]. Для этого существует специальная операция, записываемая как [image].

Рис. 6. Пример одновременного поиска нескольких решений

Изменения коснулись и части получения результата. В данном случае функция Find вернет вектор из двух элементов, которые мы обозначили как X и Y. Каждый из этих элементов есть вектор значений x или y для решений. Соответственно первое решение - (-1; -2); второе решение - (2; 4).

Аналитическое решение линейных и нелинейных систем уравнений

Данное решение используется для получения решений в общем виде. Обычно при этом система уравнений записывается только с использованием буквенных обозначений переменных, без конкретных чисел. Для получения аналитического решения (рис. 7, 8) используется оператор аналитического вычисления « [image] » вместо оператора числового вычисления «=».

Рис. 7. Пример аналитического решения нелинейной системы

Рис. 8. Пример аналитического решения линейной системы

Следует обратить внимание, что здесь при решении системы нелинейных уравнений в блоке Given-Find уже нет необходимости указывать начальные приближения, поскольку решение идет не численными, а символьными методами (используется ядро математической системы Maple).


Работа с последовательностями

Лекция No 3

Работа с последовательностями. Законы вычисления элементов матриц

MathCAD позволяет задавать значения элементов матриц не только по отдельности, но и путем определения общих законов вычисления элементов. При этом возникает необходимость определить границы действия законов, то есть диапазоны изменения индексов матриц. Для этого широко используются последовательности.

Замечание: в MathCAD нумерация элементов векторов и матриц начинается с нуля.

Пример. Ряд чисел Фибоначчи определяется по следующим правилам:

F1 = 1; F2 = 1;

Fi = Fi-1 + Fi-2; i>2.

Данный ряд бесконечен. Но мы не можем определить в MathCAD бесконечные последовательности, возможно лишь нахождение части ряда. Поэтому вместо указания i>2 необходимо задать конкретный диапазон изменения индекса i, например нас могут интересовать члены ряда со третьего по восьмой. Решение показано на рис. 9.

Рис. 9. Вычисление части ряда чисел Фибоначчи в MathCAD

Здесь сначала определен диапазон изменения индекса i, затем заданы значения двух первых членов ряда и записана общая формула для вычисления члена с индексом i. Последняя часть (столбец значений) есть часть ряда F3 .. F8, вычисленная системой. Такой порядок записи выражений объясняется тем, что MathCAD вычисляет формулы последовательно, в порядке «слева направо и сверху вниз». При вычислении члена F3 по заданной рекуррентной формуле системе уже должны быть известны реальные значения F1 и F2. Поэтому они должны быть записаны до этой формулы.

Пример. Рассмотрим численное интегрирование явным методом Эйлера.

Сначала кратко рассмотрим суть метода. Пусть дано дифференциальное уравнение в общем виде:

; x(t0) = x0;

.

Необходимо проинтегрировать данное уравнение. Если функция F(x,t) достаточно сложна, то такое уравнение может не иметь очевидного аналитического решения. В таких случаях необходимо использовать приближенные численные методы, к которым и относится метод Эйлера.

Прежде всего необходимо заменить производную каким-либо приближенным соотношением. Воспользуемся определением производной:

.

К сожалению, компьютеры не могут непосредственно работать с бесконечно малыми величинами. Поэтому перейдем к конечным величинам:

.

Такая простая формула будет тем точнее, чем меньше [image]. В любом случае в решение вносится погрешность, которая будет оказывать более или менее существенное влияние на соответствие результата точному решению. Рассмотрение этого вопроса выходит за рамки данного пособия. В первом приближении можно рекомендовать выбирать [image] в диапазоне [image].

Далее вводится дискретное время:

где [image] - шаг интегрирования по времени; [image] - номер конечного шага интегрирования. Функцию F(x,t) можно вычислять как в точке (xi,ti), так и в точке (xi+1,ti+1) - это не влияет на точность метода, хотя может влиять на характер роста погрешности. Первый вариант соответствует явному методу Эйлера, второй - неявному.

Получаем выражение

,

из которого следует расчетная формула явного метода Эйлера

.

Рассчитаем переходный процесс в электрической цепи:

Учитывая, что здесь сумма напряжений на резисторе и конденсаторе равна нулю, а ток, протекающий через резистор, равен току через конденсатор, то есть [image], можно вывести дифференциальное уравнение

.

Пусть R = 1, C = 1 с начальным условием Uc(0) = 1. Введем дискретное время:

;

где h - шаг интегрирования по времени; N - номер конечного шага интегрирования. Воспользуемся расчетной формулой явного метода Эйлера

; [image];

.

Предположим, что нас интересуют пять итераций с шагом по времени 0,1. Решение можно записать в двух формах (рис. 10).

а) б)

Рис. 10. Две формы записи решения в MathCAD

Форма (а) более проста, но не позволяет записывать решения систем дифференциальных уравнений, правые части которых являются взаимозависимыми. Вторая форма (б) более универсальна.

Полученный вектор Uc содержит значения Uc(ti) для заданных дискретных моментов времени. Можно легко убедиться, что полученное численное решение похоже на точное аналитическое [image]. Добавим следующие выражения:

и сравним полученные значения R (точное решение) и Uc. В MathCAD существуют специальные стандартные средства интегрирования дифференциальных уравнений (функция rkfixed, блок Given-Odesolve), которые будут рассмотрены далее.


Функции и графики функций

Лекция No 4

Функции и графики функций

MathCAD допускает определение на листе новых функций от одного и более аргументов. Определение записывается в строчку в следующем порядке:

1. Имя новой функции. На имена функций распространяются те же правила, что и на имена переменных.

2. Список аргументов в круглых скобках через запятую.

3. Стандартный символ присваивания «:=».

4. Выражение, определяющее значение функции от аргументов.

Обращение к функции записывается в традиционной математической форме: упоминание имени функции, сразу после которого идет список значений аргументов в круглых скобках через запятую.

Пример:

Построение графиков

Возможно построение следующих типов графиков:

1. Линейный (в прямоугольных и полярных координатах).

2. Линии уровня поверхности.

3. Поверхность.

4. Столбиковая диаграмма.

5. Точечный и векторный графики поверхности.

Для построения любого графика необходимо сначала определить на листе все данные, необходимые для построения, затем вставить на лист соответствующий графический регион и связать его с отображаемыми данными. Для вставки графического региона можно использовать соответствующие кнопки панели Graph либо выбрать требуемый пункт в верхнем меню Insert\Graph (или Вставка\График). Связь с отображаемыми данными производится путем указания этих данных в позициях ввода графического региона.

Для регионов линейных графиков (рис. 11) заполняются две основные позиции ввода - слева и снизу от графика.

а) б)

Рис. 11. Вид региона для линейного графика до (а) и после (б) заполнения одной из основных позиций ввода

В нижней позиции 2 указывается выражение, определяющее значения абсцисс графика. Выражение - имя последовательности, вектора или обычной переменной. Может быть несколько выражений через запятую. При необходимости можно указать в дополнительных позициях 3 и 4 минимальное и максимальное значения.

В позиции 1 указывается выражение, определяющее значения ординат графика. Можно перечислить несколько выражений через запятую - в этом случае будет построено несколько графиков в одних координатах. Выражения обычно являются функциями от аргумента, указанного в позиции 2. Тем не менее, могут быть построены и графики от двух функций заданных параметрически, в этом случае в позициях 1 и 2 указываются имена этих функций (рис. 12).

Рис. 12. Фрагмент листа MathCAD с линейными графиками двух функций (параметрической (x(t); y(t)) и обычной f(t))

Для регионов графиков поверхностей заполняется одна позиция ввода. Для графиков вида z = f(x,y) указывается либо имя соответствующей функции от двух переменных, либо имя матрицы, содержащей значения z.

Для параметрических графиков (заданных функциями вида x = f1(u,v); y = f2(u,v); z = f3(u,v)) есть два способа построения. Рассмотрим наиболее универсальный способ. Построим график конусовидной поверхности, заданной параметрически:

Пусть параметр u изменяется от 0 до [image] с шагом [image], а параметр v - от 0 до 15 с шагом 1. Необходимо определить законы вычисления трех матриц, каждая из которых будет содержать значения одной из координат точек поверхности. Число измерений каждой матрицы обычно равно числу параметров поверхности (в данном случае матрицы двумерные). Индексы последних элементов матрицы по каждому измерению определяются по формуле [image], где pmax, pmin - максимальное и минимальное значения параметров соответственно; ps - шаг параметра. Индексы первых элементов матриц равны нулю.

На листе MathCAD (рис. 13) сначала определяются последовательности, определяющие диапазоны изменения индексов матриц. Затем записываются законы вычисления векторов, содержащих значения параметров. Данные законы имеют общий вид [image], где p - вектор параметров; k - индекс. Далее записываются законы вычисления матриц с координатами. Такими законами являются исходные параметрические выражения для координат, в которых вместо имен параметров подставляются элементы соответствующих векторов параметров. В последнюю очередь добавляется регион графика поверхности, где в позиции ввода в круглых скобках через запятую перечисляются имена трех матриц, содержащих значения координат x,y,z, причем размерности матриц должны совпадать.

Второй способ построения параметрических поверхностей: на листе непосредственно записываются три параметрические функции, определяющие координаты, добавляется регион графика поверхности, после чего в позиции ввода региона в круглых скобках через запятую перечисляются имена указанных функций (без параметров).

Рис. 13. Построение конусовидной поверхности в MathCAD

Недостаток второго способа: MathCAD выберет диапазоны изменения параметров самостоятельно. Такой способ вполне пригоден для построения различных поверхностей вращения, все параметры которых находятся под функциями синуса или косинуса (например, тор или сфера).

Изменить различные параметры отображения графиков можно в специальном окне настроек, которое вызывается из раздела верхнего меню (Format\Graph или Форматирование\График).


Решение задач нецелочисленной оптимизации

Лекция No 5

Решение задач нецелочисленной оптимизации

Задача нецелочисленной оптимизации состоит в том, чтобы подобрать такие значения аргументов целевой функции, при которых данная функция принимает экстремальное (минимальное или максимальное) значение и соблюдается заданная система ограничений на значения аргументов. В математической форме задача может быть сформулирована следующим образом:

где f - целевая функция; n - количество аргументов целевой функции; gi, hi - элементы системы ограничений (равенств или неравенств различного вида); k - количество ограничений.

Пример задачи оптимизации. Предположим, что некоему студенту необходимо сдать два зачета в один день. Он поставил себе задачу сдать их как можно лучше, причем так, чтобы оценка за каждый зачет была не меньше 2,5 баллов. У него осталось 24 часа. Студент предположил, что, потратив один час на первый предмет, он повысит возможную оценку на 0,5 балла, потратив тот же час на второй предмет, - повысит оценку по нему на 0,25 балла. Необходимо определить, сколько часов (x) ему надо потратить на первый предмет и сколько (y) на второй предмет, чтобы выполнить поставленную задачу. Математически задача запишется так:

(сумма оценок по предметам),

и должны выполняться следующие ограничения:

В системе MathCAD такие задачи решаются с помощью блоков Given-Maximize и Given-Minimize. Так же, как и при решении систем уравнений, решающий блок состоит из нескольких компонент, следующих на листе (рис. 14) в строго определенном порядке:

1. Присваивание начальных значений переменным, относительно которых решается задача оптимизации.

2. Определение целевой функции.

3. Директива Given.

4. Ограничения, записываемые в обычной математической форме. Могут использоваться все указанные выше знаки отношений, но вместо простого знака равенства «=» используется оператор логического равенства (вводится путем нажатия Ctrl-=). Замечание: система MathCAD при минимизации и максимизации воспринимает знаки строгого неравенства (<, >) как знаки нестрогого неравенства [image].

5. Обращение к одной из функций Minimize или Maximize для соответственно минимизации или максимизации. Первым аргументом всегда является имя целевой функции. Далее следуют имена переменных, относительно которых решается задача. Функция возвращает вектор значений, где первый элемент соответствует первой переменной в списке аргументов, второй элемент - второй переменной и так далее.

Рис. 14. Решение задачи о студенте в системе MathCAD

Здесь система MathCAD определила, что решением задачи являются значения: x = 10 часов, y = 14 часов.


Численное решение дифференциальных уравнений

Лекция No 6

Численное решение дифференциальных уравнений

Рассмотрим стандартные средства численного решения дифференциальных уравнений и систем дифференциальных уравнений.

  1. Численное решение одного дифференциального уравнения

    2. MathCAD 2000 позволяет без дополнительных преобразований численно решить дифференциальное уравнение, явно разрешенное относительно старшей производной (рис. 15).

    а) б)

    Рис. 15. Примеры уравнений, разрешенного (а) и неразрешенного (б) относительно старшей производной

    Решение осуществляется с помощью специального блока Given-Odesolve, состоящего из следующих компонент:

    1. Директива Given.

    2. Дифференциальное уравнение, записанное в традиционной математической форме со следующими особенностями: а) вместо простого знака равенства «=» используется оператор логического равенства (вводится нажатием Ctrl-=); б) при обозначении интегрируемой функции всегда указывается аргумент (то есть вместо функции x(t) нельзя писать просто x); в) при записи производных используются либо стандартные операторы [image] и [image], либо ставятся (с помощью Ctrl-F7) символы производной, например x’(t), x’’(t).

    3. Указание начальных или конечных значений интегрируемой функции и ее производных (за исключением старшей), входящих в уравнение. Значения вводятся в традиционной форме с использованием оператора логического равенства. Число значений должно совпадать с порядком уравнения. Для уравнения второго порядка вида [image] должны быть заданы начальные значения функции и ее первой производной, например x(0) = 1; x’(0) = 0,5. Для ввода символа производной «’» используется комбинация клавиш Ctrl-F7.

    4. Обращение к функции Odesolve. Первый аргумент - всегда имя независимой переменной. Второй аргумент - конечное значение независимой переменной. Третий (необязательный) аргумент - количество промежуточных точек решения. Odesolve возвращает функцию, представляющую приближенное (численное) решение дифференциального уравнения на заданном интервале времени. Данная функция может быть использована для определения значений интегрируемой функции в различных точках, а также для построения графика.

    Пример. Решим вышеуказанное дифференциальное уравнение при значениях t = 0..5; найдем значения x при t = 2; 4, и построим график решения.

    Численное решение систем дифференциальных уравнений с использованием Odesolve возможно только начиная с версии MathCAD 11. В более старых версиях можно воспользоваться специальными функциями (rkadapt, rkfixed, bulstoer).

  2. Численное решение систем обыкновенных дифференциальных уравнений

    3. Дифференциальные уравнения, входящие в систему, должны иметь первый порядок (то есть содержать только первые производные). Все уравнения должны быть предварительно разрешены относительно производных и записаны в нормальной форме вида

    .

    Для преобразования уравнений в нормальную форму есть два основных подхода:

    1. Понижение порядка уравнений путем замены переменных. Если исходное дифференциальное уравнение порядка q (q>1) имеет вид

    ,

    то вводятся новые переменные pj, причем j = 1..q-1. В исходном уравнении производится серия замен:

    ,

    а производная высшего порядка заменяется производной первого порядка:

    .

    Добавляется q – 2 новых уравнений вида

    .

    Добавляется еще одно уравнение

    .

    Например, уравнение

    можно преобразовать в систему уравнений:

    2. Приведение системы дифференциальных уравнений к явному виду путем ее решения относительно производных. Например, решая систему

    относительно [image] и [image], получим:

    Рассмотрим решение систем дифференциальных уравнений в MathCAD на примере задачи о моделировании динамики электрической цепи, показанной на рис. 16.

    Динамика описывается следующей системой дифференциальных уравнений:

    Рис. 16. Электрическая цепь

    где Uc - напряжение на конденсаторе. Пусть [image]; i1(0) = i2(0) = Uc(0) = 0; [image]; L1 = 0,02; L2 = 0,06; M = 0,01; R = 0,5; C = 0,01.

    Решение записывается следующим образом:

    1. Определяются все константы и вспомогательные функции, присутствующие в правой части системы.

    2. Определяется специальная функция, вычисляющая правую часть системы. Функция имеет два аргумента: первый - независимая переменная (например, время t), второй - вектор текущих значений зависимых переменных. Результатом функции должен быть вектор, содержащий значения правых частей системы, вычисленных по значениям второго аргумента функции. Векторы имеют столько элементов, сколько уравнений в системе. При записи правых частей все зависимые переменные заменяются элементами вектора – второго аргумента, причем используется следующее правило: нулевому элементу соответствует переменная, производная от которой стоит в левой части первого уравнения; первому элементу - переменная, производная от которой стоит в левой части второго уравнения и так далее. В приведенном далее примере, где второй аргумент функции обозначен как Y, элементу Y0 соответствует i1 - переменная из производной в левой части первого уравнения, элементу Y1 соответствует i2 - переменная из производной в левой части второго уравнения, элементу Y2 соответствует UC.

    3. Задается вектор начальных значений независимых переменных.

    4. Обращение к функции rkfixed. Первый аргумент - вектор начальных значений. Второй и третий - соответственно начальное и конечное значения независимой переменной. Четвертый аргумент - число промежуточных точек решения (обычно достаточно большое число в диапазоне [image]). Пятый - имя функции, вычисляющей правую часть системы. Функция rkfixed возвращает матрицу, в нулевом столбце которой находятся значения независимой переменной, а в прочих столбцах - соответствующие значения зависимых переменных.

    Решение показано на рис. 17.

    Рис. 17. Запись решения задачи в MathCAD

    На рис. 18 показаны графики i2(t), Uc(t). Данным переменным соответствуют второй и третий столбцы матрицы S.

    Рис. 18. Графики i2(t), Uc(t)


Некоторые стандартные функции MathCAD

Лекция No 7

Некоторые стандартные функции MathCAD

Рассмотрим некоторые стандартные функции системы MathCAD. Введем специальные обозначения для аргументов функций. Пусть первый символ имени аргумента обозначает его тип:

M - квадратная матрица;

V - вектор (матрица из одного столбца);

A - произвольная матрица;

S - симметричная матрица;

G - произвольная матрица или число;

X - вектор или число;

Z - комплексная матрица или число;

z - комплексное число;

прочие символы - скалярные величины.

Экспоненциальные и логарифмические функции

exp(X) - экспонента от X;

ln(X) - натуральный логарифм от X;

log(X) - десятичный логарифм от X;

log(X,b) - логарифм от X по основанию b.

Гиперболические и тригонометрические

(прямые и обратные) функции

sin(X), cos(X), tan(X), cot(X), sec(X), csc(X) - соответственно синус, косинус, тангенс, котангенс, секанс, косеканс от X, причем аргументы указываются в радианах;

sinh(X), cosh(X), tanh(X), coth(X), sech(X), csch(X) - аналогичные гиперболические функции;

asin(z), acos(z), atan(z), acot(z), asec(z), acsc(z) - соответственно арксинус, арккосинус, арктангенс, арккотангенс, арксеканс, арккосеканс от z.

Функции для работы с комплексными числами

Re(Z), Im(Z) - соответственно вещественная и мнимая части комплексного числа Z;

arg(z) - аргумент комплексного числа z (в радианах).

Матричные функции

length(V) - возвращает число элементов вектора V;

cols(A) - возвращает число столбцов матрицы A;

rows(A) - возвращает число строк матрицы A;

matrix(m,n,f) - матрица размером mxn, значения элементов матрицы определяются f - функцией f(i,j) от двух переменных (номера строки и номера столбца). Эта функция должна быть предварительно определена пользователем;

identity(n) - единичная матрица [image];

tr(M) - след матрицы M (сумма элементов главной диагонали);

rank(A) - ранг матрицы M;

norme(M) - эвклидова норма матрицы M, то есть корень квадратный из суммы квадратов всех элементов;

eigenvals(M) - вектор, элементы которого являются собственными числами матрицы M;

eigenvecs(M) - матрица, состоящая из нормализованных собственных векторов матрицы M;

cholesky(S) - возвращает нижнетреугольную матрицу L - результат разложения Холецкого вида [image];

lu(M) - возвращает матрицу размера [image], состоящую из трех соединенных матриц P, L, U, являющихся результатом LU-разложения вида [image].

Пример вычислений с матричными функциями: нахождение собственного числа путем решения матричного уравнения [image] и с помощью функции eigenvals.

Элементы статистического анализа данных

gmean(G1,G2,G3…) - среднее геометрическое аргументов;

mean(G1,G2,G3…) - среднее арифметическое аргументов;

var(G1,G2,G3…) - дисперсия;

stdev(G1,G2,G3…) - среднеквадратичное отклонение.

Дискретные преобразования

fft(V1), ifft(V2) - прямое и обратное быстрые преобразования Фурье над вещественными данными. V1 - вектор из 2m элементов, V2 - вектор из 1 + 2m-1 элементов, m>2;

cfft(A), icfft(A) - прямое и обратное преобразования Фурье над вещественными и комплексными векторами и матрицами;

wave(V), iwave(V) - прямое и обратное вейвлет-преобразования, V - вектор из 2m элементов, m - целое число.

Аппроксимация, интерполяция и экстраполяция

Аппроксимация - поиск функции, которая с заданной степенью точности описывает исходные данные.

Интерполяция - определение наиболее правдоподобных промежуточных значений в интервале между известными значениями (подбор гладкой кривой, проходящей через заданные точки или максимально близко к ним).

Экстраполяция - определение наиболее правдоподобных последующих значений на основании анализа предыдущих значений (предсказание дальнейшего поведения неизвестной функции).

Применяются следующие функции MathCAD:

regress(VX,VY,k) - возвращает вектор данных, используемый для поиска интерполирующего полинома [image] порядка k. Полином должен описывать данные, состоящие из упорядоченных значений аргумента (VX) и соответствующих значений неизвестной функции (VY), то есть график полинома должен проходить через все точки, заданные координатами (VX,VY), или максимально близко к этим точкам;

interp(VS,VX,VY,x) - возвращает интерполированное значение неизвестной функции при значении аргумента x. VS - вектор значений, который вернула функция regress. VX,VY - те же данные, что и для regress. Функции interp и regress используются в паре;

predict(V,m,n) - возвращает вектор из n предсказанных значений на основании анализа m предыдущих значений из вектора V. Предполагается, что значения функции в векторе V были получены при значениях аргумента, взятых последовательно, с одинаковым шагом. Используется алгоритм линейной предикции. Наиболее целесообразно использовать predict для предсказания значений по данным, в которых отмечены колебания.

Для интерполяции система MathCAD использует подход, основанный на применении метода наименьших квадратов.

Примеры интерполяции и экстраполяции:

1. Пусть заданы координаты пяти точек (1; 1), (2; 2), (3; 3), (4; 2), (5; 3), представляющих результаты измерения значений некоторой неизвестной функции при различных значениях x. Необходимо подобрать интерполирующую функцию (гладкую кривую), проходящую через заданные точки.

2. Дана функция y(i) = e–i/10*sin(i). Известны значения данной функции при i = 0, 1, …, 10. Основываясь на десяти последних значениях, необходимо предсказать последующие десять значений.

Решения показаны на рис. 19.

а) б)

Рис. 19. Решения в MathCAD первой (а) и второй (б) задач

Нахождение корней полинома

polyroots(V) - возвращает вектор, содержащий все корни полинома [image], заданного вектором-столбцом коэффициентов

.

Прочие функции

max(G1,G2,…) - максимальное значение среди аргументов;

min(G1,G2,…) - минимальное значение среди аргументов;

if(a,b,c) - возвращает b, если [image], иначе возвращает c;

sign(a) - возвращает –1, 0 или 1 в зависимости от знака числа a.

На рис. 20 показан пример применения функции if.

Рис. 20. Функция, вычисляющая факториал


Элементы программирования в MathCAD

Лекция No 8

Элементы программирования в MathCAD

На одном листе MathCAD могут определяться один или несколько программных блоков. Обычно их используют при разработке функций, которые осуществляют какую-либо сложную обработку данных, например находят корень нестандартного уравнения.

Переменные. В программном блоке можно читать значения переменных, определенных в MathCAD до этого блока. Однако изменить значения этих переменных внутри программного блока невозможно. Все переменные, которым присваиваются значения внутри программного блока, будут локальными переменными, которые недоступны вне блока. Специально объявлять переменные не нужно, достаточно просто присвоить им значения. Если программный блок является телом функции, то он также может читать значения аргументов этой функции.

Программный блок представляет собой группу операторов присваивания и управляющих операторов. Необходимо обратить особое внимание, что все ключевые слова (например, if) в этих операторах обязательно вводятся с помощью панели Programming (Программирование). Их ввод с клавиатуры - ошибка!

В целом правила работы с операторами те же, что и в языке Pascal, отличия касаются способа записи операторов.

Таблица 2. Соответствие программных операторов MathCAD и Pascal

Оператор языка Pascal | Оператор MathCAD | Комментарий
A := B |  | Присваивание
Begin оператор1; оператор2; … End |  | Группа, объединяющая несколько операторов в один составной оператор. Для создания группы и добавления в нее новой пустой строчки используется кнопка «Add Line» панели Programming
If условие Then оператор If условие Then Begin оператор1; оператор2; … End | оператор if условие | Простой оператор ветвления. Как и в языке Pascal, его действие распространяется на один указанный оператор, который может быть группой операторов. Условием может быть любое логическое выражение, которое может содержать знаки отношения (вместо обычного знака равенства используется знак логического равенства) и логические операторы (находятся на панели Boolean): - Not; - And; - Or; - Xor
If условие Then оператор1 Else оператор2 |  | Полный оператор ветвления
For инд := нач To кон Do оператор |  | Фиксированный оператор цикла. Индексная переменная принимает значения от начального до конечного с шагом, равным единице. Цикл действует на один указанный оператор, который может быть группой операторов
While условие Do оператор |  | Гибкий оператор цикла с предусловием. Цикл выполняется, пока истинно заданое условие
Break Continue | break continue | Оператор break принудительно завершает текущий цикл. Оператор continue завершает только текущий виток цикла и начинает следующий виток
Нет прямого аналога | выражение1 on error выражение2 | Специальная операция обработки ошибок. Сначала вычисляется выражение2. Если при этом происходит ошибка, то результатом операции будет выражение1. Если ошибки нет, то результат - выражение2. Пример: Здесь локальная переменная A получает значение 2, переменная B - значение 0,5

Использование программных блоков в функциях

Если функция является программным блоком, то значение, которое возвращает функция, - это обычно значение, которое вычислено последним сработавшим оператором блока. Иногда возникает необходимость досрочно завершить работу блока и вернуть какое-либо иное значение - для этого используется оператор вида

return значение,

который также вводится с помощью панели Programming. Его выполнение заканчивает работу текущего программного блока.

Примеры:

1. Функция, возвращающая –1, 0 или 1 в зависимости от знака аргумента.

2. Пусть интегрируется дифференциальное уравнение

;

; [image],

где параметр z определяется в результате решения нелинейного уравнения

.

Известно, что в рассматриваемом случае это нелинейное уравнение имеет единственное решение. Создадим функцию, которая решает данное уравнение методом касательных с заданной точностью ?.

Функция Solve возвращает значение z, которое является корнем уравнения при заданном значении x. Решение дифференциального уравнения:


Основы системного использования ЭВМ. Работа с системой MathCAD

 К содержанию

Введение

  1. Основные сведения. Простые вычисления.
  2. Решение систем уравнений с помощью блока Given-Find.
  3. Работа с последовательностями. Законы вычисления элементов матриц.
  4. Функции и графики функций.
  5. Решение задач нецелочисленной оптимизации.
  6. Численное решение дифференциальных уравнений.
  7. Некоторые стандартные функции MathCAD.
  8. Элементы программирования в MathCAD.


Введение

Ивановский государственный энергетический университет

Высокопроизводительных вычислительных систем

Электронный конспект лекций

по курсу

"Основы системного использования ЭВМ. Работа с системой MathCAD"

Пекунов В.В.,

кандидат технических наук, старший преподаватель

Введение

Во многих случаях в инженерной практике решаются разнообразные математические задачи. В настоящее время существуют универсальные математические пакеты, например MathCAD, MatLAB, Mathematica, позволяющие оперативно решать такие задачи. При этом система MathCAD выгодно отличается простотой освоения, возможностями ввода и редактирования формул в естественной для человека форме, имеет достаточную мощность для большинства инженерных расчетов.

Курс содержит сведения, позволяющие освоить основные возможности системы MathCAD: решение систем линейных и нелинейных уравнений; работу с последовательностями; построение графиков; решение задач оптимизации; численное интегрирование; интерполяцию и экстраполяцию; элементы программирования.

Курс предназначен для студентов специальностей 100200 и 100400, изучающих курс «Основы системного использования ЭВМ» или любой курс, связанный с проведением значительных математических расчетов.